All times are UTC-06:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu May 04, 2006 5:13 am 
Hello everybody !
I've posted this on Gentoo forum this morning but did not have any answer :-(

So, I'm doing a :
"emerge kde gnome openoffice koffice mozilla-firefox eclipse-sdk apache mysql"

And after many hours (days !) of emerging I have this error on "app-arch/file-roller-2.12.3/help"

"LookupError : no codec search functions registred : can't find encoding" (after a look at "gettext.py" it seems).

I've search google a bit and found that it might come from a missing import called "encodings" (Unicode ?) in Python scripts.
I've tried to modify a script (gettext.py) adding "encodings" on the "import" line but without success (and I'm not a Python expert at all either).

So I came back to the original version and did a "emerge --resurme --skipfirst" to continue emerging with others package but I encounter the same errors on other packages like "gnome-panels-2.12.3/help/fish".

Could somebody help on this ?
Thx a lot ;-)
Best regards.

Note : atm, I just did a new emerge command skipping gnome.


Last edited by lugduweb on Wed May 24, 2006 5:56 am, edited 1 time in total.

Top
   
 Post subject:
PostPosted: Thu May 04, 2006 10:20 am 
Offline

Joined: Mon Mar 27, 2006 12:16 pm
Posts: 79
Have you already read this and tried reemerging libxml, libxml2 and libxslt?


Top
   
 Post subject:
PostPosted: Thu May 04, 2006 1:35 pm 
Nope !
I'm going to try (but my Gentoo disk is full now !
too bad, I thought 6GB was enough !).


Top
   
 Post subject:
PostPosted: Thu May 04, 2006 1:42 pm 
Offline

Joined: Mon Mar 27, 2006 12:16 pm
Posts: 79
Take a good look at /usr/portage/distfiles. That's where all the source packages get stored (by default). You may want to clean that directory out from time to time.


Top
   
 Post subject:
PostPosted: Thu May 04, 2006 3:29 pm 
Ok, I've created a partition for /usr/portage (I don't know why but I can't resize my partition any more with parted or gparted since I've used it under Ubuntu 6.06 dapper beta).

So I'm now emerging libxml&cie and openoffice (at the same time - hope that's ok).
I will try then to emerge gnome again later.


Top
   
 Post subject:
PostPosted: Tue May 09, 2006 12:35 pm 
OK, I've tried a "emerge dev-libs/libxml libxml2 libxslt" on Friday.
Today I've tried another "emerge gnome" and unfortunatly I still have the same error :-(

Any other idea ?


Top
   
 Post subject:
PostPosted: Tue May 09, 2006 1:11 pm 
It's a Python issue.
Quote:
emerge python dev-libs/libxml libxml2 libxslt gnome-doc-utils gnome
solves the problem with success :-)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group