All times are UTC-06:00




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat May 05, 2012 6:31 am 
Offline

Joined: Wed May 02, 2012 11:21 am
Posts: 16
I don't have video, when I play big buck bunny (http://mirror.bigbuckbunny.de/peach/big ... stereo.ogg) using totem. I have the following packages of which I think are related installed:

i imx-boot-scripts - modules, rc.local for improved performance
i imx-firmware - Firmware binary package.
i A imx-freescale-eula - Freescale EULA package
i imx-libc-neon - LD_PRELOADed NEON optimized libc functions
i imx-powermanagement-config - Settings for powermanagment for suspend/re
i imx-sysctl-rules - sysctl rules for improved performance on F
i A imx-udev-rules - udev rules for devices on Freescale i.MX p
i A libc2d-z160-imx - Common 2D acceleration API for Z160 unit -
i A libc2d-z430-imx - Common 2D acceleration API for Z430 unit -
i libegl1-imx - EGL native platform graphics interface lib
i libegl1-imx-dev - EGL native platform graphics interface lib
i libgles1-imx - OpenGL|ES 1.x API -- runtime for Freescale
i libgles2-imx - OpenGL|ES 2.x API -- runtime for Freescale
i A libkgsl-imx - Graphics System Layer Interface Library fo
i libopenvg1-imx - OpenVG API -- runtime for Freescale i.MX p
iBA xserver-xorg-video-imx - X.Org X server -- i.MX display driver

Any suggestions?


Top
   
 Post subject:
PostPosted: Sat May 05, 2012 10:28 am 
Offline
Genesi

Joined: Mon Jan 30, 2006 2:28 am
Posts: 409
Location: Finland
Hi.

Can you try the mp4 version of the video?


Johan.

_________________
Johan Dams, Genesi USA Inc.
Director, Software Engineering

Yep, I have a blog... PurpleAlienPlanet


Top
   
 Post subject:
PostPosted: Sat May 05, 2012 11:00 am 
Offline

Joined: Wed May 02, 2012 11:21 am
Posts: 16
With the mp4 version I have video, but no sound which is AC-3, by the way. I checked with the film Sintel (http://www.sintel.org/download) which also has AC-3 sound, video works fine, audio not.

So it seems that I cannot play Theora video nor AC-3 sound.


Top
   
 Post subject:
PostPosted: Sat May 05, 2012 11:25 am 
Offline
Genesi

Joined: Mon Jan 30, 2006 2:28 am
Posts: 409
Location: Finland
Hi.

Can you verify that you have the AC-3 codec installed? I think it's in gst-plugins-bad and gst-plugins-ugly.


Johan.

_________________
Johan Dams, Genesi USA Inc.
Director, Software Engineering

Yep, I have a blog... PurpleAlienPlanet


Top
   
 Post subject:
PostPosted: Sat May 05, 2012 11:41 am 
Offline

Joined: Wed May 02, 2012 11:21 am
Posts: 16
Both, the bad and the ugly set, are installed.

While playing a file with AC-3 sound, I hear nothing and the cpu is on 100%, if I skip sone seconds, I hear quite short sound. It seems that the decoding of audio is not fast enough for the video.


Top
   
 Post subject:
PostPosted: Mon May 07, 2012 1:55 pm 
Offline

Joined: Sun Mar 27, 2011 1:18 pm
Posts: 183
Location: Hornell, NY
This is a known problem I have been talking about on IRC for quite a while now. I have sent an SD card image to the person that maintains our gstreamer plugins so he can try and fix this problem (and other video problems on armhf). I don't know when he will have time to look at it though since he is working on another project right now.

I don't intend to let this (or other problems with the Debian armhf packages) fall through the cracks. particularly since I'm the one that has to test all of this stuff in the first place.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC-06:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
PowerDeveloper.org: Copyright © 2004-2012, Genesi USA, Inc. The Power Architecture and Power.org wordmarks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.
All other names and trademarks used are property of their respective owners. Privacy Policy
Powered by phpBB® Forum Software © phpBB Group