Power Developer

armhf: hangs on resume (solved)
Page 1 of 1

Author:  alexis [ Wed Mar 21, 2012 1:40 pm ]
Post subject:  armhf: hangs on resume (solved)


I have an SD with the latest armhf image, dist-upgraded on a regular basis to keep up-to-date. I modified the boot script to show the console on tty1 and have a verbose boot. I also have uninstalled slim and put lightdm back.

Overall it works fine, except one thing : suspend/hibernate.

Either can be selected from lightdm's menu, or "Suspend" from Xfce's logout dialog.

Both result in the same behavior : after several seconds, the screen goes black, the backlight turns off and the machine seems to sleep.

A short press on the power button switches the backlight up, displays (too briefly to read) some kind of wake-up log in text mode, the X display is restored... and the machine hangs hard. No keyboard/mouse, no network access, only a hard reboot (long press on the power button) works.

I haven't been able to google anything relevant.

Suggestions ?

Author:  steev [ Wed Mar 21, 2012 2:03 pm ]
Post subject: 

Try adding a file to /etc/pm/config.d (or whatever the Debian equivalent is) named 10_efikamx with the following in it:
Since network and keyboard/mouse are on the USB bus, this sounds like the likely culprit.

Author:  alexis [ Wed Mar 21, 2012 4:52 pm ]
Post subject: 

That did it, thanks.

And there goes my last obstacle to switching full-time to debian-armhf. I'll even consider moving it to the internal storage now :)

Page 1 of 1 All times are UTC-06:00
Powered by phpBB® Forum Software © phpBB Group